Checkhealth recommendation is awkward

I’m using neovim in alacritty with tmux and the only appropriate configuration is using

set-option -g default-terminal "xterm-256color"
set-option -ga terminal-overrides ",${TERM}:RGB"

as tmux.conf, and

  TERM: xterm-256color

as alacritty config; with these configs both colors and fonts are ok, but - :checkhealth is complaining about that TERM configuration, like:

  - ERROR: $TERM should be "screen-256color" or "tmux-256color" in tmux. Colors might look wrong.
    - ADVICE:
      - Set default-terminal in ~/.tmux.conf:
          set-option -g default-terminal "screen-256color"

But with TERM=screen-256color fonts become broken and with TERM=tmux-256color whole shell become broke with error

can't find terminal definition for tmux-256color

So what is wrong with using xterm-256color inside tmux, so :checkhealth consider this as error?

Finally enable tmux-256color after updating ncurses by this guide