Coc-java-vimspector - error when trying to run it

Hi I’m trying to get Vimspector to work in neovim, right now I’ve only tried on a Java file.

I got the neovim from my debian package manager, but it was an old version, so I’ve downloaded the NVIM v0.5.1 nvim.appimage file, and tried to do the same thing, but I get the same error…don’t know if it a configuration problem…

F5 key doesn’t do anything, so I enter ’ :CocList mainClassListRun ’ into nvim, and I select the only class there is in the directory. Then I get the following error:

[coc.nvim]: UnhandledRejection: request error nvim_eval - Vim:E117: Unknown function: vimspector#LaunchWithSettings                                            
    at wF.request (/home/kaushan/.vim/plugged/coc.nvim/build/index.js:30:34430)
    at wF.eval (/home/kaushan/.vim/plugged/coc.nvim/build/index.js:33:3288)
    at Object.startVimspector (/home/kaushan/.config/coc/extensions/node_modules/coc-java-vimspector/lib/index.js:17703:38)

I do have to say, I have not made an ‘eclipse project’ for the Java file. this is just a .java and .class file in a directory.

This is the configurations file I have in that directory :

	"configurations": {
		"CodeLens (Launch) - Board": {
			"adapter": "vscode-java",
			"default": true,
			"breakpoints": {
				"exception": {
					"caught": "N",
					"uncaught": "N"
			"configuration": {
				"classPaths": [
				"type": "java",
				"name": "CodeLens (Launch) - Board",
				"request": "launch",
				"console": "externalTerminal",
				"mainClass": "Board",
				"projectName": "project GD_board_5071b16"

Do you guys have any ideas to help? I’ve worked long to get debugging working in vim and nvim and am at end of my effort here.