Cursor jumping to top-right corner of window?


  • neovide GUI with default cursor animations
  • neovim v0.8.0-dev-1093-g982fef601-dirty
  • treesitter installed


Occasionally when I type, the cursor seems to be jumping a bit to the top-right corner of the window. Because I’m using neovide’s default cursor animation you can see it dashing back to where I am typing.

This is a scratch file I just set the ft to typescript but when editing a ts file in a project, it’s a lot more noticeable.

2022-09-29 15.18.44

Any thoughts about what is causing that? Or at least somewhere to look to begin debugging that?

GitHub - neovide/neovide: No Nonsense Neovim Client in Rust

1 Like

Good call! In hindsight, neovide issues should have been the first place I looked.

Someone reported an identical issue and determined the cause is in neovim’s tabline rendering which moves the cursor on updates causing the jump.

Setting vim.o.showtabline = 0 does fix the jumping, but of course hides the tabline. In the GH issue, seems the cursor jumping might have a lot to do with the “x” close button on the right corner. Might try tweaking the tabline and see if that can be improved without having to completely disable the feature, I don’t use that button anyway.

UPDATE: Installed GitHub - seblj/nvim-tabline: Tabline for neovim written in lua which is a bit nicer than default and seems to prevent the cursor from jumping.