Don't include newline on visual selection when using `$`

For a while, I’ve had this behavior where using $ while in visual mode doesn’t include the newline.

I just updated to 0.9 and this doesn’t work anymore :frowning:

The problem is that I don’t know what I did to have that behavior. I don’t know if there’s a native option in neovim or it comes from a plugin. I just know that the behavior changed in 0.9

Does anyone have an idea how I might restore the old behavior back?

Thanks in advance

I was a happy user of a bug in which-key.nvim: '$' will only go to the left character of real line end in visual mode · Issue #290 · folke/which-key.nvim · GitHub

The bug seems fixed on Neovim 0.9 :frowning:

You can start with vmap $ $h.