Help HTML formatting clossing tags

I got a problem when I try to type < It will automatically add > so the result is <|>, now the alvan/vim-closetag wont work correctly because there is already > on the tag.

How I can prevent Neovim to do not add > when I try to add html tags.

What I observe is, this will just happen after I run prettier to format the code.

This will only happen if the useTabs option on the prettier is set to true.

From what I know neovim does not come with any tag auto closing functionality. So maybe you have two plugins trying to do the same thing?

To test It’s not neovim, test without any plugin or configuration nvim -u NONE test.html

Thanks I just disable the html angle bracket on coc-pairs

1 Like