Shift-Space escape sequence in :term introduced between in neovim 0.6 and 0.7

I’m a bit of a sloppy typist and often when I’m typing I will do a shift space instead of a space. In all environments (tried different terminals, including inside tmux) outside of the neovim terminal, shift space is just space. However I discovered that somewhere between 0.6 and 0.7 the terminal now receives the shift-space escape sequence. You can confirm going into a terminal, running read and hitting shift-space. In 0.7 you will see ^[[32;2u and in 0.6 you will just see a space.

The sequence has an undesirable affect in seemingly all readline environments (tried with zsh, bash, and rlwrap). It does some kind of undo / redo if I spam it, haven’t figured out exactly what action this is.

Confirmed the behavior difference using these docker images anatolelucet/neovim:0.6.0 and anatolelucet/neovim:0.7.0

I’m wondering if that is intentional (aka not a bug) and if so how to suppress that?

You can suppress it by doing:

tnoremap <S-Space> <Space>

Yeah I’m honestly happy with a workaround. That’s perfect thanks.