Spell-check popup menu (mouse right-click) fails to appear


System: fresh install of Debian 11 (Bullseye), KDE-minimal, neovim-qt

I’m a long-time vi/vim/gvim user who is switching to nvim/nvin-qt.
I’m unable to get the spell-check popup menu (mouse right-click) to appear in nvim/nvim-qt.

Below is my test “~/.config/nvim/init.vim” file:

" Enable mouse support
 set mouse=a
"set mouse=nv

" Enable mouse right-click popup menu showing work options
"behave mswin
"behave xterm
"set mousemodel=popup_setpos
 set mousemodel=popup

" Enable spell checking
"setlocal spell spelllang=en_us
 set spell

"      Here is a misspelled word: mispeled

Using “nvim ~/.config/nvim/init.vim”, I’ve tried:

  1. nvim and nvim-qt
  2. two types of terminals (Konsole and Termit)
  3. multiple combinations of “init.vim” parameters

nvim is detecting the misspelled word above (misspelled word is highlighted).
Unfortunately, nvim fails to produce the spell-check popup menu (mouse right-click).

I’ve searched through the documentation for differences between vim and nvim: Nvim documentation: vim_diff
Unfortunately, I’ve failed to find a difference that explains this problem.

What am I doing wrong in my setup?
Any help appreciated.

P.S. Also, is there a “newbie” sub-forum for nvim? My question is basic and I dislike wasting advanced peoples time with it.

Not sure what’s exactly wrong, it could be just the terminal not accepting the right mouse click like how vim accepts it. From the code you pasted it should work, the docs on this I found where at :help mouse-overview maybe I’m also missing something. I’ve tried it on my pc and laptop with both terminal and gui and also get the same problem, even with only setting:

set mouse=a
behave mswin -- changes the mousemodel automatically

It’s quite rare to see someone use a mouse with vim, not to say you’re wrong to use it. Usually, I wouldn’t use mouse when using vim (but to each their own :slightly_smiling_face:), however I can suggest if you want to open the spell check suggestion you can press <C-x><C-s> in insert mode on the word and it will show the popup menu, once you have set spell on. :help compl-spelling

Sorry wasn’t much help with the mouse issue :frowning:

Thank you for the input.
I’m doing further testing on nvim-qt vs. gvim. gvim has gtk3 speed issues. nvim-qt has mouse issues (spell-check and cut/paste). I’m working on fixing both sets of issues. Hopefully, at least one of them will work.
Again, thanks for the help.