Clangd snippets not working correctly, need to use range format on them somehow

Read this please first and the answer.
I’m using nvim-cmp, but how to automatically apply range format on snippet when completion is done? Any idea? Because without snippet support - clangd sucks, i don’t want to disable them.