How can I disable the snippets from clangd

I’d like to use my own snippets, so the clangd’s snippets is redundant for me.

I have tried to disable it in lspconfig:

require("lspconfig").clangd.setup({
	capabilities = {
		textDocument = {
			completion = {
				completionItem = {
					snippetSupport = false,
				},
			},
		},
	},
})

But it doesn’t work.

Anyone can help me to disable the snippets from lsp? Much appreciated!!