Git diff highlighting are not working anymore in gitcommit filetype

Hello,

I use git commit -v to have the git diff display in the editor when I commit. Until a couple of months ago, the diff was correctly highlighted, but one day, it stops to highlight the diff. Since I run neovim HEAD, I thought this would get fixed after a couple of days / weeks, but it didn’t, and now I’m wondering if something change that I’m supposed to enable to have my diff highlighting work again.

It was working out of the box and I checked the GitHub issue about HEAD breaking change, but I didn’t find anything that could help me. I’ve also asked on IRC, but nobody had any idea, so if you have an idea, let me know.

Works for me:

This is weird, because I’ve tried with the latest stable version of neovim, and it doesn’t work either. I’ll try to play with my config to see what’s going on.

[edit]

I just comment out my treesitter config, and it starts to work again, so I’ll try to find what’s missing there.

[edit2]

Got it, the issue is with the gitcommit treesitter’s parser. I disable it and it works now.

1 Like