Is there any way to adjust trackpad scroll speed in Neovim?

I use Neovim inside Kitty. In Kitty, I have adjusted the trackpad scroll speed so I can scroll decently fast:

touch_scroll_multiplier 10.0

This works great when scrolling in the terminal itself. It also works great for scrolling in full-screen terminal applications like pagers and man pages.

However, when I open Neovim, scrolling on the trackpad is horribly, horribly slow. How come scrolling is slower inside Neovim? Is there anything I can do to configure this?

Two options:

  1. Disable mouse support:
:set mouse=
  1. Change the ‘mousescroll’ option:
set mousescroll=ver:10

Thanks, setting mousescroll=ver:10 makes things a lot more usable, but it seems like the main issue is the number of scroll events that reach Neovim. How is that determined? It would be a much better experience if Neovim received 10x the number of scroll events, so I could scroll 1 line at a time at the same speed.

According to, kitty’s touch_scroll_multiplier shouldn’t take effect in a program that has enabled mouse support.

Yeah it seems so. I still have no idea if my issue is with Kitty or with Neovim, though.

Can I increase the frequency of ScrollWheelUp/ScrollWheelDown events inside Neovim? Or does Neovim just produce these events as they come in from Kitty?

Have you tried option one of what @zeertzjq suggested?

Yes, forgot to mention that. When I set mouse= then scrolling in Neovim using the trackpad no longer works at all, instead I scroll upwards in the parent Kitty terminal.