Japanese characters via the clipboard are garbled

When I yank Japanese text in neovim and then paste it, the text is garbled.
The problem is fixed by using the following settings, but in 0.4, the characters were not garbled even without the settings, so is this a bug?

vim.api.nvim_command("language en_US")

The clipboard settings are always the following

vim.opt.clipboard = "unnamedplus"

That is not a valid locale – you must specify an encoding, as in

language en_US.UTF-8

(or the actual locale you want to use).

Is there a lua API to change the language?

vim.cmd("languange en_US.UTF-8")