Lspconfig reporting no such file or directory for ngserver(angular language server) on windows10

Hi, i’m running into some trouble configuring the angular language server on windows. It keeps reporting that ngserver is not a file or directory.

unfortunately lsp.log doesn’t have much.
[ START ] 2021-03-14T23:31:42+0000 ] LSP logging initiated

i can run ngserver from the command line.

I can also run other language servers, the tsserver works and on my Arch machine everything works.

Here is the error message i get
E5113: Error while calling lua chunk: …gram Files\Neovim\share\nvim\runtime\lua\vim\lsp\rpc.lua:380: start `ngserver` failed: ENOENT: no such file or directory.

Any idea on what could be causing this?
I assume i either missed something really obvious or there is a compatibility issue with Windows 10.

I’m thinking of running on WSL, everything worked there, but fzf is slower on WSL

Thanks in advance

Try setting the server command to ngserver.cmd or making sure ngserver is on your path (you should be able to start ngserver in the shell prior to opening neovim).

Thank you so much setting the command to ngserver.cmd solved it.