This annoying little bug about the my status-line behaviour

There’s this weird cropping/cutting that happens to the filetype icons on my status-line.


I’m using lua-line but I don’t think this is lua-line specific because I’ve experienced similar issue with the line-nr symbol of vim-airline.

I’m using Manjaro and my terminal emulator is Konsole and I don’t think this is an issue of rendering because the terminal and other sections of my vim (buffer-line, nvim-tree) renders it just fine. Just when it comes to the status-line this annoying little bug occur.

Here’s a link to the GitHub issue thread if it helps: Bug: Filetype icons gets cropped · Issue #485 · nvim-lualine/lualine.nvim · GitHub
As they suggested I tried changing fonts, installed powerline fonts (it came up when I was searching for patched fonts) but nothing helped. If anyone can help me out with this, it’d bring me inner-peace :slight_smile: . Thanks.

Some terminals have this issue. Try using kitty.

1 Like

Thanks, someone on the lua-line repo suggested this and it works now. Thanks for your reply. Didn’t know Konsole has this weird behaviour.:neutral_face:.