Installing fzf.vim with nightly

Hi everyone!

I’m trying to install fzf.vim using vim-plug (and have the fzf binary installed via my distribution’s package manager). I noticed that having just fzf.vim installed via vim-plug doesn’t enable fzf in neovim-nightly but have to explicitly install the binary using vim-plug. Whereas, in the case of v0.5, just fzf.vim via vim-plug works with system package manager installed fzf binary.

Is there a workaround for nightly where I just install fzf.vim via vim-plug?

In theory, it should work as you said. But according to the installation docs it’s recommended to install both junegunn/fzf and junegunn/fzf.vim for it to work properly.

This shouldn’t mess with your globally installed fzf binary if you have it, as it will install it locally just for nvim.

Edit: actually it will pick up the globally install fzf binary instead of installing one locally, more info was in their readme: fzf/ at master · junegunn/fzf · GitHub

1 Like

Yes! it does pick up the globally installed one automatically with v0.5 but not with nightly. I’d like to make it work with nightly as well.

1 Like

Did you install both the plugins? Because it’s working when I tried it on nightly version (NVIM v0.6.0-dev+197-g636ecd0c3) compiled it just now.

I installed fzf globally, that comes with ubuntu and it picked that up no problem (besides it complaining that it’s the older version), and also through local installation i.e. install both plugins and then :Files command will prompt to install the fzf binary.

I have it in vim-plug like this (w/o the fzf#install option):

Plug 'junegunn/fzf'
Plug 'junegunn/fzf.vim'
1 Like