Installing neovim latest stable from source WSL1 ubuntu

I’m trying to get the latest (stable) version of NeoVim on my work machine. I have WSL1 (cant activate 2 because of bios settings), running Ubuntu 20.04. i’ve tried:

  • updating PPA: ERROR: not a user or team name
  • AppImage: error in squash-root Error: cannot execute binary file: Exec format error
  • Building from source:
    • Steps:
      • Installed build prerequisites
      • switched to root user
      • ran this command: make CMAKE_BUILDTYPE=Release CMAKE_INSTALL_PREFIX=/usr/local/bin/ install
      • I recieve several failed notices like this one: FAILED: build/src/lua-compat-5.3-stamp/lua-compat-5.3-download
      • Followed by:
  file RENAME failed to rename

    /home/rrhughes/neovim/.deps/build/src/ex-tree-sitter1234/tree-sitter-0.20.1

  to

    /home/rrhughes/neovim/.deps/build/src/tree-sitter

  because: Permission denied

build stops with ninja: build stopped: subcommand failed. make: *** [Makefile:107: deps] Error 1
I’m at the end of my rope. I simply can not find anyway to install latest neovim on this machine. Any help would be greatly appreciated

Have you tried Homebrew? Also works for Linux and WSL.

1 Like

Wow… I wish I knew that 3 days ago when I started down this road lol. Turns out i figured out my problem with the app image though. I was actually able to turn on WSL2 after rebooting my PC… duh. And in WSL2 the FUSE package actually works.