Nvimdiff is broken and have no clue why

So I’ve been having a strange problem for over a month now and hoping someone can point me in the right direction on resolving. A few months back I started using nvimdiff tool to help resolve merge conflicts. I added this to my config to setup key binds in that diffmode to easily select which chunk I want to use.

if vim.opt.diff:get() == true then
  keymap('n', '<C-f>', '<cmd>diffget LOCAL<CR>', opts)
  keymap('n', '<C-j>', '<cmd>diffget REMOTE<CR>', opts)
  keymap('n', '<leader>w', '<cmd>wqa<CR>', opts)

Whenever there would be a merge conflict, I would call git mergetool with nvimdiff as the default merge and diff tool. This worked for a little while, but is now broken. I now get this layout and none of my keybinds are mapped, so it’s like it doesn’t register the diffmode.

But if I run the mergetool with vimdiff, the layout is set properly.

I am on the NVIM v0.8.0-dev-2260-g3030b4d65 installed via homebrew on a Macbook. My same configuration on a fedora mini-pc stick works properly, being built from master just like the Macbook. I have nuked my neovim installation and tried rebuilding from scratch and from source and nvimdiff seems broken on my Macbook.

Does anyone have any suggestions or any ideas what may have happened? I’m happy to provide any additional information.