Underscores highlighted in signature help

I’m using clangd for c++ development.
When the signature help pops up underscores are highlighted in red (background), it seems like nvim or clangd thinks this is an error somehow.
To be honest I’m not sure where this highlighting is coming from exactly, but I would like to turn it of if possible…

Any information on this topic would be appreciated.

See https://github.com/neovim/neovim/issues/13746.
The specific issue you are seeing may have been fixed very recently. If you haven’t done so lately you could try to update to the latest hash?

I think this is mostly due to your colorscheme. You can find the value that’s highlighting the by looking through :hi:

First, find the highlight group. You can do this via the following keymap:

  function! SynStack ()
    for i1 in synstack(line("."), col("."))
        let i2 = synIDtrans(i1)
        let n1 = synIDattr(i1, "name")
        let n2 = synIDattr(i2, "name")
        echo n1 "->" n2
   map gm :call SynStack()<CR>
]], false)

Toggle into the floating win with <c-w> <c-w>, put your cursor on the _, and type gm
The highlight group for ( as an example is:

cpp1 -> cpp1
cParen -> cParen

Which for my colorscheme is:

:hi cParen
cParen         xxx cleared

I have just updated to the latest nightly build, but the red highlighting is still present.

Ah how did I not think about the colorscheme…

I have disabled my colorscheme, but the problem is still present. I also tought it might have been my terminal color scheme, but I’ve tried in a different terminal, and this didn’t make a difference.

I have tried your suggestion, but I can’t use <c-w> <c-w> to move my cursor into the signature help window. This does work with the hover window, but not for the signature help window.

Same for me:

See if this PR helps.

It does not seem to change anything for me. I’m also not seeing the highlighting in the screenshot in your pull request.

I think I build this correctly (I’ve pulled the pull request, checked out your feature branch, and run make and sudo make install on that).

Could have anything to do with my lsp configuration? I basically copied the default one, enabled clangd and attached my completion plugin (completion-nvim)

Works for me (I’m not using comp-e or completion-nvim to test). I’d try checking your color scheme and making sure the branch successfully compiled and installed.

Ah yes it only happens when I attach the completion plugin. I might try and install compe again tomorrow, to see if it has the same problem.

EDIT: I’ve looked at completion-nvim’s code, and I think they open the signature window in another way, so a similar fix should probably be applied there.

Completion-nvim’s development seems to be on pause. Worst case, my fix is easily applied in both plugins and you can point the authors to my PR.